Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Oct 06, 2025 - 16:50 BST
Monitoring
Twilio engineers are observing improvement for the service interruption with the Function Invocations API, where function invocations can fail with a 500 error. They expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 06, 2025 - 15:55 BST
Update
Twilio engineers are investigating a service interruption with the Function Invocations API, Functions invocations can fail with 500 error. They expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 06, 2025 - 15:42 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Oct 06, 2025 - 15:36 BST
This incident affected: Twilio (Twilio Functions).