Twilio - Errors updating alerts in flex admin console

Incident Report for Ciptex

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 21:54 BST

Investigating

Twilio are currently seeing errors updating alerts in flex admin console. Twilio engineering team is looking into the issue. We will provide another update as soon as more information becomes available.
Posted Sep 23, 2025 - 21:49 BST