Twilio are no longer experiencing high latency with video room sessions. This incident has been resolved.
Posted Jun 06, 2026 - 05:39 BST
Monitoring
Twilio are observing recovery on the latency issue with video room sessions. They will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 06, 2026 - 03:48 BST
Update
Twilio are currently investigating issues with video room sessions. Customers could experience high latency when connecting to video room. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 06, 2026 - 03:08 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Jun 06, 2026 - 03:03 BST
This incident affected: Twilio (Twilio Go Rooms, Twilio Compositions, Twilio Recordings, Twilio Peer-to-Peer Rooms, Twilio Group Rooms).