Twilio - Dual Channel Conference Recording Failure in IE Region

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 18, 2025 - 00:18 GMT

Update

We are continuing to investigate this issue.
Posted Nov 17, 2025 - 23:35 GMT

Investigating

Twilio is investigating a potential issue with dual channel conference recording failing in IE1 region. They expect to provide another update in 1 hours or as soon as more information becomes available
Posted Nov 17, 2025 - 23:31 GMT
This incident affected: Twilio (Twilio Recording, Twilio Conference).