Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Sep 14, 2026 - 18:29 BST
Identified
Twilio customers may be experiencing voice call failures from a subset of Twilio United States Phone Numbers to network subscribers in Iraq. Twilio has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 14, 2026 - 13:58 BST
Update
Twilio customers may be experiencing voice call failures from a subset of Twilio United States Phone Numbers to Korek Telecom network subscribers in Iraq. Twilio team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 14, 2026 - 12:58 BST
Update
Twilio customers may be experiencing voice call failures from a subset of Twilio United States Phone Numbers to Korek Telecom network subscribers in Iraq. Twilio team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 14, 2026 - 10:52 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Sep 14, 2026 - 10:51 BST
This incident affected: Twilio (Twilio Voice, Middle East & Africa).