Twilio -Inbound Call Failures to Twilio German Phone Numbers

Incident Report for Ciptex

Resolved

This incident has been resolved.
Posted May 07, 2025 - 16:40 BST

Update

Twilio are observing Inbound Call Failures to Twilio German Phone Numbers. Twilio are currently working with their carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available
Posted May 07, 2025 - 16:02 BST

Investigating

We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted May 07, 2025 - 16:00 BST
This incident affected: Twilio (Twilio Voice, Europe).