Failure to connect calls in US2 region
Incident Report for Ciptex
Resolved
Twilio are no longer experiencing call connecting issue in US2 region. This incident has been resolved.
Posted Jul 23, 2024 - 12:46 BST
Monitoring
Twilio are observing recovery in their service. We will continue monitoring the service to ensure a full recovery. We will provide another update as soon as more information becomes available.
Posted Jul 23, 2024 - 12:12 BST
Investigating
Twilio are experiencing a potential issue to connect calls in US2 region. Twilio engineers are working to resolve the issue. We will provide another update as soon as more information becomes available.
Posted Jul 23, 2024 - 10:55 BST
This incident affected: Twilio (Twilio PSTN).