YouSign service interrupted

Incident Report for Ciptex

Resolved

The YouSign incident has been resolved, and the service is operating normally.
Posted Dec 03, 2025 - 15:58 GMT

Monitoring

A fix for the issue has been implemented, and the team is monitoring the service.
Posted Dec 03, 2025 - 14:39 GMT

Investigating

YouSign is currently experiencing a service interruption. The engineering team has identified the issue and is working on a fix. Further updates will be issued as soon as more information becomes available.
Posted Dec 03, 2025 - 14:35 GMT
This incident affected: Race Engage (Race ESign).