Twilio - Call Quality Issue to a Subset of Twilio Phone Numbers in UK

Incident Report for Ciptex

Resolved

We are no longer seeing the call quality issues to a subset of Twilio phone numbers in UK. This incident has been resolved.
Posted Mar 21, 2025 - 09:47 GMT

Update

Twilio continues to observe call quality issues to a subset of Twilio phone numbers in UK. They are currently working with their carrier partner to resolve the issue and expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Mar 20, 2025 - 09:42 GMT

Update

Twilio continues to observe call quality issues to a subset of Twilio phone numbers in UK. They are currently working with their carrier partner to resolve the issue and expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 19, 2025 - 22:36 GMT

Update

We are continuing to observe call quality issues to a subset of Twilio phone numbers in UK. Twilio are currently working with their carrier partner to resolve the issue. We expect to provide another update as soon as more information becomes available.
Posted Mar 19, 2025 - 13:59 GMT

Investigating

Twilio are observing call quality issues to a subset of Twilio phone numbers in UK. Twilio are currently working with their carrier partner to resolve the issue. We expect to provide another update as soon as more information becomes available.
Posted Mar 19, 2025 - 12:39 GMT
This incident affected: Twilio (Twilio PSTN, Twilio Voice, Europe).