Potential issue affecting Twilio Video

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 08, 2025 - 00:25 GMT

Monitoring

The Video Service’s connectivity issue is now operating normally. Users should be able to use all Video functionality without errors. Twilio will continue to monitor for system stability. We'll provide another update as soon as more information becomes available.
Posted Nov 07, 2025 - 07:23 GMT

Update

Twilio's automated systems have detected a potential issue affecting the Twilio Video service, related to joining the actual call. Twilio engineers are working to resolve the issue. We'll update you in 1 hour or as soon as more information becomes available.
Posted Nov 07, 2025 - 02:03 GMT

Investigating

We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Nov 07, 2025 - 01:50 GMT
This incident affected: Twilio (Twilio Group Rooms).