Twilio - Increased Latency for Multiple Twilio Services

Incident Report for Ciptex

Resolved

All services impacted due to increased latency for multiple Twilio services have recovered and are operating as intended. This incident has been resolved.
Posted Jul 03, 2025 - 04:45 BST

Investigating

Twilio engineers have identified the issue with increased latency for multiple Twilio services and continue monitoring the situation. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jul 03, 2025 - 02:01 BST