Twilio has completed their investigation and determined that this event did result in a subset of customer's impact. Twilio have contacted impacted customers to provide additional information about the incident.
Posted Jun 04, 2026 - 21:47 BST
Update
Twilio customers may be experiencing SMS delivery failures between a subset of Twilio Short Codes and network subscribers on multiple networks in Ireland. The Twilio team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 04, 2026 - 21:27 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Jun 04, 2026 - 21:24 BST
This incident affected: Twilio (Twilio SMS, Twilio SMS, Europe).