Twilio - Account settings page errors
Incident Report for Ciptex
Resolved
This incident has been resolved.
Posted Nov 30, 2024 - 21:10 GMT
Monitoring
Twilio Console is now operating normally.We will continue to monitor for system stability.We will provide another update as soon as more information becomes available.
Posted Nov 30, 2024 - 20:20 GMT
Investigating
Twilio are currently investigating a service interruption with the account settings page. Customers may receive an error "we are having trouble loading this page due to a server error".
We expect to provide another update as soon as more information becomes available
Posted Nov 30, 2024 - 17:01 GMT
This incident affected: Twilio (Twilio Console).