Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 13, 2025 - 14:19 GMT
Monitoring
Flex Insights Historical Reporting platform is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 13, 2025 - 14:02 GMT
Update
Twilio are currently experiencing an outage with Flex Insights due to an issue with their BI vendor. We will provide further updates in 1 hour or as they become available.
Posted Nov 13, 2025 - 13:19 GMT
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Nov 13, 2025 - 13:16 GMT
This incident affected: Twilio (Twilio Flex Insights).