Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 20, 2025 - 23:27 GMT
Monitoring
Twilio engineers have deployed a fix and are monitoring performance. Please note that this issue impacted webhook responses and did not impact Voice calls. Twilio is hoping to provide next update in 30 minutes.
Posted Nov 20, 2025 - 23:02 GMT
Update
We are continuing to investigate this issue.
Posted Nov 20, 2025 - 22:56 GMT
Investigating
We are currently aware of issues affecting inbound and outbound call handling for customers using Twilio Voice. Calls may fail, and webhook requests may return error code 15000. This issue originates from Twilio’s platform and is actively being investigated on their side.
Our systems are operating normally, but affected workflows may experience disruptions due to Twilio’s degraded service. We will provide updates as more information becomes available.