Increased Error Rate on Twilio Messaging APIs

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 12, 2025 - 23:33 GMT

Update

We are continuing to investigate this issue.
Posted Nov 12, 2025 - 21:33 GMT

Investigating

From 20:45 - 20:47 and 20:59 - 21:01 UTC, customers using Twilio APIs may have seen an unexpected increase in 503 errors. Their engineers are currently investigating and will provide more information as it becomes available.
Posted Nov 12, 2025 - 21:25 GMT
This incident affected: Twilio (Twilio REST API).