Twilio has confirmed that they are no longer experiencing the outage with the Flex Insights Historical Reporting platform. This incident has been resolved.
Posted Oct 29, 2025 - 20:18 GMT
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 19:47 GMT
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 19:46 GMT
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 19:36 GMT
Investigating
Twilio is currently experiencing an outage with Flex Insights Historical Reporting platform due to an issue with their BI vendor, GoodData. As a result, the GoodData UI is inaccessible and historical data is unavailable across impacted workspaces. At this time, 71 customers are affected, and the number may continue to increase. They are actively working with the vendor to resolve the issue as quickly as possible. Please expect next update in 1 hour.
Posted Oct 29, 2025 - 19:19 GMT
This incident affected: Twilio (Twilio Flex Insights).