Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Nov 06, 2025 - 18:10 GMT
Investigating
Twilio are continuing to observe call quality issues from a subset of Twilio's Numbers in the United Kingdom. Twilio Engineers are currently working with their carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 06, 2025 - 12:08 GMT
Monitoring
Twilio are observing recovery of call quality issues from a subset of Twilio's Numbers in the United Kingdom. Twilio Engineers are currently monitoring the issue to ensure full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 06, 2025 - 11:30 GMT
Update
Twilio are observing call quality issues from a subset of Twilio's Numbers in the United Kingdom. Twilio Engineers are currently working with their carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 06, 2025 - 10:33 GMT
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Nov 06, 2025 - 10:28 GMT
This incident affected: Twilio (Twilio Voice, Europe).