Firebase Outage Impacting Notification Delivery for Twilio Customers

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Sep 01, 2026 - 14:07 BST

Monitoring

We have started seeing recovery in an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery.

This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users. Our teams are actively monitoring the situation and we will provide an update in 30 minutes or as more information becomes available.
Posted Sep 01, 2026 - 13:14 BST

Update

Twilio are experiencing an active Firebase outage that is impacting notification delivery for some Twilio customers. Customers using Twilio products that rely on Firebase Cloud Messaging may experience disrupted or delayed notification delivery.

This issue is related to an upstream Firebase service disruption and may affect push notification delivery to end users.

Our teams are actively monitoring the situation and we will provide an update in 1 hour as more information becomes available.
Posted Sep 01, 2026 - 12:44 BST

Investigating

We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Sep 01, 2026 - 12:40 BST
This incident affected: Twilio (Twilio Conversations, Twilio Authy 2FA).