Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted Sep 09, 2026 - 21:28 BST
Update
We have observed a recovery in voice calls from a subset of Twilio Phone Numbers to Verizon network subscribers in the United States and are monitoring service stability.
We will provide another update in 4 hours or as soon as more information becomes available.
Posted Sep 09, 2026 - 21:24 BST
Monitoring
We have observed a recovery in voice calls from a subset of Twilio Phone Numbers to Verizon network subscribers in the United States and are monitoring service stability.
We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 09, 2026 - 19:22 BST
Update
Our customers may be experiencing voice call failures from a subset of Twilio Phone Numbers to Verizon network subscribers in the United States, our team is actively investigating this issue.
We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 09, 2026 - 18:59 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Sep 09, 2026 - 18:53 BST
This incident affected: Twilio (Twilio Voice, North America).