Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted May 09, 2026 - 13:23 BST
Monitoring
The incident affecting cross region connectivity is now operating normally. Twilio will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted May 09, 2026 - 12:25 BST
Update
Twilio are currently still investigating issues affecting cross region connectivity. Customers could experience degradation of calls traversing between regions. We will provide another update in 4 hours or as soon as more information becomes available.
Posted May 09, 2026 - 08:12 BST
Update
Twilio are currently still investigating issues affecting cross region connectivity. Customers could experience degradation of calls traversing between regions. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 09, 2026 - 06:17 BST
Update
Twilio are currently investigating issues affecting cross-region connectivity. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 09, 2026 - 05:15 BST
Investigating
We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.