Microsoft 365 Issues may impact your ability to send and receive email
Incident Report for Ciptex
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 11:57 GMT
Investigating
We have been made aware in the news this morning that Microsoft is experiencing issues with 365 services. This may affect your ability to report issues by email to our service desk or to receive email replies. Please call our service desk if you would like to verify if we have received your ticket until Microsoft have resolved this issue +44 345 8800 808
Posted Jan 25, 2023 - 09:09 GMT
This incident affected: Ciptex Cloud (Ciptex NOC General Notifications).