Twilio - Flex insights dashboards is not accessible
Incident Report for Ciptex
Resolved
Twilio are no longer experiencing issues with Flex Insights Dashboards not being accessible. This incident has been resolved.
Posted Mar 25, 2024 - 13:35 GMT
Investigating
Twilio monitoring systems have detected a potential issue with Flex insights boards which currently not accessible. Their engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 25, 2024 - 12:39 GMT
This incident affected: Twilio (Twilio Flex Insights).