SMS delivery failures to H3G in the United Kingdom of Great Britain and Northern Ireland

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted May 13, 2025 - 01:38 BST

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 01:23 BST

Investigating

Twilio is experiencing SMS delivery failures to H3G in the United Kingdom of Great Britain and Northern Ireland. Their engineers are working with their carrier partner to resolve the issue and expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 13, 2025 - 01:19 BST
This incident affected: Twilio (Twilio SMS, Europe).