Twilio - Users may experience issues when logging into Twilio Console
Incident Report for Ciptex
Resolved
Users are no longer experiencing intermittent login issues when using the account portal. This incident has been resolved.
Posted Mar 11, 2024 - 02:30 GMT
Investigating
Twilio is currently seeing degraded performance on their account portal, where some users may experience intermittent login issues. The Twilio engineering team is looking into the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 11, 2024 - 00:23 GMT
This incident affected: Twilio (Twilio Console).