The issue affecting inbound calls to Twilio Toll-free Numbers from Canadian Phone Numbers has been resolved, and the service is functioning normally at this time.
Posted Mar 19, 2025 - 10:52 GMT
Update
Twilio is still observing inbound call failures to a subset of Twilio Toll-free numbers from Canadian phone Numbers. They are currently working with their carrier partner to resolve the issue and expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 19, 2025 - 07:34 GMT
Update
We are continuing to investigate this issue.
Posted Mar 19, 2025 - 00:47 GMT
Investigating
Twilio has detected a potential service disruption where inbound calls are failing for Twilio's Toll-Free numbers in Canada. Their engineering team is looking into this issue and will provide further updates as soon as more information becomes available.
Posted Mar 19, 2025 - 00:42 GMT
This incident affected: Twilio (Twilio Voice, North America).