Twilio - 500 Errors When Updating Phone Numbers Configuration

Incident Report for Ciptex

Resolved

Following comprehensive monitoring, we can confirm that the incident has been fully resolved and all services have returned to normal operation.
Posted May 05, 2025 - 21:58 BST

Update

Twilio are currently investigating an elevated rate of 500 errors when updating Phone numbers configuration. Twilio engineers are working on the issue, and we will provide another update as soon as more information becomes available.
Posted May 05, 2025 - 21:19 BST

Investigating

We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted May 05, 2025 - 21:16 BST
This incident affected: Twilio (Twilio Phone Numbers).