Twilio - Errors for the Twilio Rest API Impacting Multiple Twilio Services

Incident Report for Ciptex

Update

Twilio will continue monitoring to ensure the Twilio Rest API issues impacting multiple services do not reoccur. They will be monitoring all services to confirm a full recovery and provide another update in 24 hours or as soon as more information becomes available.
Posted Aug 31, 2025 - 15:15 BST

Update

We are continuing to monitor for any further issues.
Posted Aug 30, 2025 - 23:04 BST

Monitoring

We will continue monitoring to ensure the Twilio Rest API issues impacting multiple services do not reoccur. We will be monitoring all services to confirm a full recovery and provide another update in 30 minutes or as soon as more information becomes available.
Posted Aug 30, 2025 - 12:47 BST

Update

Twilio are investigating issues impacting the Programmable Messaging API, TaskRouter, Proxy and Programmable Video starting at approximately 5:16 AM UTC. During this period, about 0.1% of Programmable Messaging API requests (~2,500 requests) returned 5xx errors. TaskRouter is seeing approximately 80 errors (503) from Proxy and Video is reporting 106 requests with status 503. We expect to provide another update as soon as more information becomes available.
Posted Aug 30, 2025 - 09:18 BST

Investigating

We have detected potential service disruption through our monitoring systems and are actively investigating. A detailed assessment of the impact and affected services will be provided within the next 30 minutes.
Posted Aug 30, 2025 - 09:12 BST
This incident affects: Twilio (Twilio SMS, Twilio TaskRouter, Twilio Proxy, Twilio Go Rooms, Twilio Network Traversal Service, Twilio Compositions, Twilio Recordings, Twilio Peer-to-Peer Rooms, Twilio Group Rooms).